Online List Manager Address Verification Issue
Incident Report for OSV Hub
Resolved
The issue with address verification has been resolved.
Posted Jan 03, 2023 - 16:44 EST
Identified
We are currently experiencing an issue with our address verification service. This impacts the ability for users to add new families or edit addresses in Online List Manager. We are actively working on a solution with our service provider for this issue.
Posted Jan 03, 2023 - 11:49 EST
This incident affected: Services (Church Manager - Address Validation).