Issue in Online Giving

Incident Report for OSV Hub

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 09:42 EDT

Identified

We have identified an issue with a recent deployment that is causing issues with some users when trying to view transactions in Online Giving or submitting new gifts. We are actively working to resolve this.
Posted Jul 09, 2025 - 09:20 EDT
This incident affected: Online Giving Website and Admin Website.